Creating the Heightmap
  • Start L3DT
  • Click File → New map → Design level
  • Each pixel in the design-map corresponds to a 64 x 64 block of heightfield pixels, so choose a 32 × 32 map wich will create a 2048 × 2048 heightfield. (Note some older graphic cards don’t support textures this big).
  • The other features should be self explanatory and you can change them to your heart content.
  • By now you should have a screen something like this :

  • Click OK
  • You will then get a rough pre-view of what the heightmap will look like, you can repeat steps before until you get something you like, or you can edit everything manually by using the Tools → DM paint tool option.
  • Ok, so you liked the heightmap at first but the Tools → DM paint tool option can still be used to add some cool features to the landscape like plateaus, vulcanos or mountains. Just check the Type box under Special overlays, choose a feature type from the combobox and click where you want the feature to be in the heightmap.
  • I added some mountains and some plateaus and by now i have this :

  • Where done now, click Operations → Heightfield → Generate map
  • The duration of this process is influenced by the map size, amount of features and your hardware spec, so it can take some minutes or several hours. For this sample it took me around 4 minutes to generate the heightmap.
  • When the heightmap is displayed click File → Export → Active map, choose an image format and save it. We will load this image as the heightmap in TV later. Although you can save it in JPEG it will be better if you save if in BMP for more accurate results.

2 - Creating the Texture

 
tutorialsarticlesandexamples/create_a_landscape_in_l3dt1.txt · Last modified: 2013/11/22 13:32